Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
R
reform-debian-packages
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Reform
reform-debian-packages
Commits
99295374
Verified
Commit
99295374
authored
1 year ago
by
Johannes Schauer Marin Rodrigues
Browse files
Options
Downloads
Patches
Plain Diff
build_custom.sh: check source.mnt.re for the version
parent
3215bf5e
No related branches found
Branches containing commit
No related tags found
1 merge request
!20
changes from reform.d.n
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
build_custom.sh
+8
-2
8 additions, 2 deletions
build_custom.sh
with
8 additions
and
2 deletions
build_custom.sh
+
8
−
2
View file @
99295374
...
@@ -105,7 +105,11 @@ if [ -z "$(reprepro listfilter reform "Package (== wayfire)")" ]; then
...
@@ -105,7 +105,11 @@ if [ -z "$(reprepro listfilter reform "Package (== wayfire)")" ]; then
rm
-Rf
"
$WORKDIR
"
rm
-Rf
"
$WORKDIR
"
fi
fi
if
[
-z
"
$(
reprepro listfilter
"
$OURSUITE
"
"Package (== reform-tools)"
)
"
]
;
then
# simplified version of $our_version from build_patched.sh because the binary
# version is always equal to the source version here
our_version
=
$(
reprepro
--list-format
'${version}\n'
-T
deb listfilter
"
$OURSUITE
"
"
\$
Source (== reform-tools)"
|
uniq
)
their_version
=
$(
curl
--silent
https://source.mnt.re/reform/reform-tools/-/raw/main/debian/changelog | dpkg-parsechangelog
--show-field
Version
--file
-
)
if
[
-z
"
$our_version
"
]
||
dpkg
--compare-versions
"
$our_version
"
lt
"
$their_version
"
;
then
rm
-Rf
"
$WORKDIR
"
rm
-Rf
"
$WORKDIR
"
mkdir
--mode
=
0777
"
$WORKDIR
"
mkdir
--mode
=
0777
"
$WORKDIR
"
(
(
...
@@ -119,7 +123,9 @@ if [ -z "$(reprepro listfilter "$OURSUITE" "Package (== reform-tools)")" ]; then
...
@@ -119,7 +123,9 @@ if [ -z "$(reprepro listfilter "$OURSUITE" "Package (== reform-tools)")" ]; then
rm
-Rf
"
$WORKDIR
"
rm
-Rf
"
$WORKDIR
"
fi
fi
if
[
-z
"
$(
reprepro listfilter
"
$OURSUITE
"
"
\$
Source (== reform-handbook)"
)
"
]
;
then
our_version
=
$(
reprepro
--list-format
'${version}\n'
-T
deb listfilter
"
$OURSUITE
"
"
\$
Source (== reform-handbook)"
|
uniq
)
their_version
=
$(
curl
--silent
https://source.mnt.re/reform/reform-handbook/-/raw/master/debian/changelog | dpkg-parsechangelog
--show-field
Version
--file
-
)
if
[
-z
"
$our_version
"
]
||
dpkg
--compare-versions
"
$our_version
"
lt
"
$their_version
"
;
then
rm
-Rf
"
$WORKDIR
"
rm
-Rf
"
$WORKDIR
"
mkdir
--mode
=
0777
"
$WORKDIR
"
mkdir
--mode
=
0777
"
$WORKDIR
"
(
(
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment