Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
R
reform-debian-packages
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Reform
reform-debian-packages
Commits
61db0b99
Verified
Commit
61db0b99
authored
1 year ago
by
Johannes Schauer Marin Rodrigues
Browse files
Options
Downloads
Patches
Plain Diff
build_patched.sh: stop building wayfire and firedecor as both packages are now in unstable
parent
f5d832b5
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
build_custom.sh
+0
-67
0 additions, 67 deletions
build_custom.sh
build_patched.sh
+3
-0
3 additions, 0 deletions
build_patched.sh
with
3 additions
and
67 deletions
build_custom.sh
+
0
−
67
View file @
61db0b99
...
...
@@ -38,73 +38,6 @@ set -u
# ./build.sh
#fi
if
[
-z
"
$(
reprepro listfilter reform
"Package (== wayfire)"
)
"
]
;
then
rm
-Rf
"
$WORKDIR
"
mkdir
--mode
=
0777
"
$WORKDIR
"
(
cd
"
$WORKDIR
"
cd
../wayfire
git clone
--recursive
https://github.com/WayfireWM/wayfire.git wayfire-src
git
-C
wayfire-src reset
--hard
04d964eeeafde3fcdb6f15a4142301a8882df41e
git
-C
wayfire-src clean
-df
WFCOMMIT
=
$(
git
-C
wayfire-src rev-parse
--short
HEAD
)
WFDATE
=
$(
date
+%Y-%m-%d
)
WFVERTAR
=
"0.8~
$WFDATE
"
WFVER
=
"wayfire_
$WFVERTAR
-git
$WFCOMMIT
"
mv
wayfire-src
"
$WFVER
"
# because debian meson.pm disables https://mesonbuild.com/Wrap-dependency-system-manual.html
cp
-Rv
wayfire-debian-wrap-workaround/
*
"
$WFVER
/subprojects/"
tar
cvfz
"
$WORKDIR
/wayfire_
$WFVERTAR
.orig.tar.gz"
"
$WFVER
"
cd
"
$WORKDIR
"
cp
-Rv
../wayfire/debian
"
$WFVER
"
cd
"
$WFVER
"
echo
"wayfire (
$WFVERTAR
-git
$WFCOMMIT
)
$OURSUITE
; urgency=medium"
>
debian/changelog
cat
debian/changelog.tail
>>
debian/changelog
sbuild
--chroot
$BASESUITE
-
$BUILD_ARCH
\
--host
=
"
$HOST_ARCH
"
\
--no-arch-all
--arch-any
\
--profiles
=
"cross,
$COMMON_BUILD_PROFILES
"
\
$COMMON_SBUILD_OPTS
\
--extra-repository
=
"
$SRC_LIST_PATCHED
"
cd
..
# build the firedecor plugin
cd
"
$WORKDIR
"
cd
../firedecor
git clone
--recursive
https://github.com/mntmn/Firedecor.git firedecor-src
FDCOMMIT
=
$(
git
-C
firedecor-src rev-parse
--short
HEAD
)
FDDATE
=
$(
date
+%Y-%m-%d
)
FDVERTAR
=
"0.1~
$FDDATE
"
FDVER
=
"firedecor_
$FDVERTAR
-git
$FDCOMMIT
"
mv
firedecor-src
"
$FDVER
"
tar
cvfz
"
$WORKDIR
/firedecor_
$FDVERTAR
.orig.tar.gz"
"
$FDVER
"
cd
"
$WORKDIR
"
cp
-Rv
../firedecor/debian
"
$FDVER
"
cd
"
$FDVER
"
echo
"firedecor (
$FDVERTAR
-git
$FDCOMMIT
)
$OURSUITE
; urgency=medium"
>
debian/changelog
cat
debian/changelog.tail
>>
debian/changelog
sbuild
--chroot
$BASESUITE
-
$BUILD_ARCH
\
--host
=
"
$HOST_ARCH
"
\
--no-arch-all
--arch-any
\
--profiles
=
"cross,
$COMMON_BUILD_PROFILES
"
\
$COMMON_SBUILD_OPTS
\
--extra-package
=
".."
# includes wayfire
dcmd
mv
-v
../
*
.changes
"
$ROOTDIR
/changes"
cd
..
)
rm
-Rf
"
$WORKDIR
"
fi
# simplified version of $our_version from build_patched.sh because the binary
# version is always equal to the source version here
our_version
=
$(
reprepro
--list-format
'${version}\n'
-T
deb listfilter
"
$OURSUITE
"
"
\$
Source (== reform-tools)"
|
uniq
)
...
...
This diff is collapsed.
Click to expand it.
build_patched.sh
+
3
−
0
View file @
61db0b99
...
...
@@ -21,6 +21,9 @@ for p in patches/*; do
continue
fi
# We print '${version}_${source}\n' and then do sed filtering to get
# to the version of the source package and discard the (possibly
# differing) version of the binary packages it builds using sed.
# shellcheck disable=SC2016
our_version
=
$(
reprepro
--list-format
'${version}_${source}\n'
-T
deb listfilter
"
$OURSUITE
"
"
\$
Source (==
$p
)"
|
sed
's/.*_.*(\(.*\))$/\1/;s/_.*//'
|
uniq
)
their_version
=
$(
chdist_base apt-get
source
--only-source
-t
"
$BASESUITE
"
--no-act
"
$p
"
|
sed
"s/^Selected version '
\\
([^']*
\\
)' (
$BASESUITE
) for .*/
\\
1/;t;d"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment