diff --git a/linux/build.sh b/linux/build.sh
index 311bbe9d4d8a4fa176157988302ed32264a3ebbc..27c353493da90458fdf0a4ed7e41f535fdab0eb6 100755
--- a/linux/build.sh
+++ b/linux/build.sh
@@ -109,10 +109,6 @@ if [ "$BUILD_ARCH" != "$HOST_ARCH" ]; then
 	DEB_BUILD_PROFILES="cross $DEB_BUILD_PROFILES"
 fi
 
-# fails to cross-build since python3.11 3.11.6-1 with:
-# cc1: error: ‘-fcf-protection=full’ is not supported for this target
-DEB_BUILD_PROFILES="nopython $DEB_BUILD_PROFILES"
-
 env --chdir=linux DEB_BUILD_PROFILES="$DEB_BUILD_PROFILES" \
 	sbuild --chroot="$BASESUITE-$BUILD_ARCH" --arch-any --arch-all --host="$HOST_ARCH" \
 		--verbose --no-source-only-changes --no-run-lintian --no-run-autopkgtest
diff --git a/linux/packaging.diff b/linux/packaging.diff
index 032353586dc615f8f0935bb3c717667294762df6..72de4899ecccb3b73365caaf60589a76e3e9cf47 100644
--- a/linux/packaging.diff
+++ b/linux/packaging.diff
@@ -60,3 +60,16 @@ index 113926e5f..5acb3fa1f 100644
 +[packages]:
 +installer: false
 +docs: false
+--- a/debian/rules.real	2023-06-12 08:25:16.000000000 +0200
++++ b/debian/rules.real	2023-06-14 16:09:09.000000000 +0200
+@@ -632,6 +632,10 @@
+ 	dh_md5sums
+ 	dh_builddeb -- $(BUILDDEB_ARGS)
+ 
++ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
++binary_perf build_perf: export _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata__$(DEB_HOST_MULTIARCH)
++endif
++
+ build_perf: $(STAMPS_DIR)/build-tools-headers
+ 	$(call make-tools,tools/perf)
+