diff --git a/linux/packaging2.diff b/linux/packaging2.diff
index b2a40c6e81df60d1847679c9b969a50657712f83..d79c316108cd252a56d9770c53b1ce995ad55554 100644
--- a/linux/packaging2.diff
+++ b/linux/packaging2.diff
@@ -183,106 +183,6 @@ index 9c4987116..02ce1b5ff 100644
   	{ MARVELL_PHY_ID_88E1111_FINISAR, MARVELL_PHY_ID_MASK },
   	{ MARVELL_PHY_ID_88E1118, MARVELL_PHY_ID_MASK },
   	{ MARVELL_PHY_ID_88E1121R, MARVELL_PHY_ID_MASK },
-diff --git a/debian/patches/bugfix/all/drm-vmwgfx-Fix-stale-file-descriptors-on-failed-user.patch b/debian/patches/bugfix/all/drm-vmwgfx-Fix-stale-file-descriptors-on-failed-user.patch
-index 13296cbfa..5360aa2c7 100644
---- a/debian/patches/bugfix/all/drm-vmwgfx-Fix-stale-file-descriptors-on-failed-user.patch
-+++ b/debian/patches/bugfix/all/drm-vmwgfx-Fix-stale-file-descriptors-on-failed-user.patch
-@@ -24,11 +24,9 @@ Signed-off-by: Mathias Krause <minipli@grsecurity.net>
-  drivers/gpu/drm/vmwgfx/vmwgfx_kms.c     |  2 +-
-  4 files changed, 21 insertions(+), 21 deletions(-)
- 
--diff --git a/drivers/gpu/drm/vmwgfx/vmwgfx_drv.h b/drivers/gpu/drm/vmwgfx/vmwgfx_drv.h
--index 858aff99a3fe..d63ba3804436 100644
- --- a/drivers/gpu/drm/vmwgfx/vmwgfx_drv.h
- +++ b/drivers/gpu/drm/vmwgfx/vmwgfx_drv.h
--@@ -1115,15 +1115,14 @@ extern int vmw_execbuf_fence_commands(struct drm_file *file_priv,
-+@@ -1140,15 +1140,14 @@ extern int vmw_execbuf_fence_commands(st
-  				      struct vmw_private *dev_priv,
-  				      struct vmw_fence_obj **p_fence,
-  				      uint32_t *p_handle);
-@@ -46,11 +44,9 @@ index 858aff99a3fe..d63ba3804436 100644
-  bool vmw_cmd_describe(const void *buf, u32 *size, char const **cmd);
-  
-  /**
--diff --git a/drivers/gpu/drm/vmwgfx/vmwgfx_execbuf.c b/drivers/gpu/drm/vmwgfx/vmwgfx_execbuf.c
--index 5f2ffa9de5c8..9144e8f88c81 100644
- --- a/drivers/gpu/drm/vmwgfx/vmwgfx_execbuf.c
- +++ b/drivers/gpu/drm/vmwgfx/vmwgfx_execbuf.c
--@@ -3823,17 +3823,17 @@ int vmw_execbuf_fence_commands(struct drm_file *file_priv,
-+@@ -3879,17 +3879,17 @@ int vmw_execbuf_fence_commands(struct dr
-   * Also if copying fails, user-space will be unable to signal the fence object
-   * so we wait for it immediately, and then unreference the user-space reference.
-   */
-@@ -71,7 +67,7 @@ index 5f2ffa9de5c8..9144e8f88c81 100644
-  
-  	memset(&fence_rep, 0, sizeof(fence_rep));
-  
--@@ -3861,20 +3861,14 @@ vmw_execbuf_copy_fence_user(struct vmw_private *dev_priv,
-+@@ -3917,19 +3917,13 @@ vmw_execbuf_copy_fence_user(struct vmw_p
-  	 * handle.
-  	 */
-  	if (unlikely(ret != 0) && (fence_rep.error == 0)) {
-@@ -83,8 +79,7 @@ index 5f2ffa9de5c8..9144e8f88c81 100644
- -			fence_rep.fd = -1;
- -		}
- -
-- 		ttm_ref_object_base_unref(vmw_fp->tfile, fence_handle,
-- 					  TTM_REF_USAGE);
-+ 		ttm_ref_object_base_unref(vmw_fp->tfile, fence_handle);
-  		VMW_DEBUG_USER("Fence copy error. Syncing.\n");
-  		(void) vmw_fence_obj_wait(fence, false, false,
-  					  VMW_FENCE_WAIT_TIMEOUT);
-@@ -94,7 +89,7 @@ index 5f2ffa9de5c8..9144e8f88c81 100644
-  }
-  
-  /**
--@@ -4212,16 +4206,23 @@ int vmw_execbuf_process(struct drm_file *file_priv,
-+@@ -4266,16 +4260,23 @@ int vmw_execbuf_process(struct drm_file
-  
-  			(void) vmw_fence_obj_wait(fence, false, false,
-  						  VMW_FENCE_WAIT_TIMEOUT);
-@@ -122,7 +117,7 @@ index 5f2ffa9de5c8..9144e8f88c81 100644
-  	/* Don't unreference when handing fence out */
-  	if (unlikely(out_fence != NULL)) {
-  		*out_fence = fence;
--@@ -4239,7 +4240,7 @@ int vmw_execbuf_process(struct drm_file *file_priv,
-+@@ -4293,7 +4294,7 @@ int vmw_execbuf_process(struct drm_file
-  	 */
-  	vmw_validation_unref_lists(&val_ctx);
-  
-@@ -131,11 +126,9 @@ index 5f2ffa9de5c8..9144e8f88c81 100644
-  
-  out_unlock_binding:
-  	mutex_unlock(&dev_priv->binding_mutex);
--diff --git a/drivers/gpu/drm/vmwgfx/vmwgfx_fence.c b/drivers/gpu/drm/vmwgfx/vmwgfx_fence.c
--index 9fe12329a4d5..b4d9d7258a54 100644
- --- a/drivers/gpu/drm/vmwgfx/vmwgfx_fence.c
- +++ b/drivers/gpu/drm/vmwgfx/vmwgfx_fence.c
--@@ -1159,7 +1159,7 @@ int vmw_fence_event_ioctl(struct drm_device *dev, void *data,
-+@@ -1128,7 +1128,7 @@ int vmw_fence_event_ioctl(struct drm_dev
-  	}
-  
-  	vmw_execbuf_copy_fence_user(dev_priv, vmw_fp, 0, user_fence_rep, fence,
-@@ -144,11 +137,9 @@ index 9fe12329a4d5..b4d9d7258a54 100644
-  	vmw_fence_obj_unreference(&fence);
-  	return 0;
-  out_no_create:
--diff --git a/drivers/gpu/drm/vmwgfx/vmwgfx_kms.c b/drivers/gpu/drm/vmwgfx/vmwgfx_kms.c
--index 74fa41909213..14e8f665b13b 100644
- --- a/drivers/gpu/drm/vmwgfx/vmwgfx_kms.c
- +++ b/drivers/gpu/drm/vmwgfx/vmwgfx_kms.c
--@@ -2516,7 +2516,7 @@ void vmw_kms_helper_validation_finish(struct vmw_private *dev_priv,
-+@@ -2501,7 +2501,7 @@ void vmw_kms_helper_validation_finish(st
-  	if (file_priv)
-  		vmw_execbuf_copy_fence_user(dev_priv, vmw_fpriv(file_priv),
-  					    ret, user_fence_rep, fence,
-@@ -157,6 +148,3 @@ index 74fa41909213..14e8f665b13b 100644
-  	if (out_fence)
-  		*out_fence = fence;
-  	else
---- 
--2.30.2
--
 diff --git a/debian/patches/bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch b/debian/patches/bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
 index 701376417..187b3c0a9 100644
 --- a/debian/patches/bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
@@ -1207,27 +1107,10 @@ index 701376417..187b3c0a9 100644
  @@ -3712,16 +3712,13 @@ static int bnx2_request_uncached_firmwar
   	}
   
-@@ -1285,28 +1147,9 @@ Index: linux/drivers/net/ethernet/broadcom/bnx2.c
+@@ -1285,11 +1147,9 @@ Index: linux/drivers/net/ethernet/broadcom/bnx2.c
   	mips_fw = (const struct bnx2_mips_fw_file *) bp->mips_firmware->data;
   	rv2p_fw = (const struct bnx2_rv2p_fw_file *) bp->rv2p_firmware->data;
   	if (bp->mips_firmware->size < sizeof(*mips_fw) ||
--Index: linux/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c
--===================================================================
----- linux.orig/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c
--+++ linux/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c
--@@ -13420,11 +13420,8 @@ static int bnx2x_init_firmware(struct bn
-- 	BNX2X_DEV_INFO("Loading %s\n", fw_file_name);
-- 
-- 	rc = request_firmware(&bp->firmware, fw_file_name, &bp->pdev->dev);
---	if (rc) {
---		BNX2X_ERR("Can't load firmware file %s\n",
---			  fw_file_name);
--+	if (rc)
-- 		goto request_firmware_exit;
---	}
-- 
-- 	rc = bnx2x_check_firmware(bp);
-- 	if (rc) {
 -Index: linux/drivers/net/ethernet/broadcom/tg3.c
 -===================================================================
 ---- linux.orig/drivers/net/ethernet/broadcom/tg3.c
@@ -2733,93 +2616,6 @@ index 1f4784597..e191d1411 100644
   	$(call if_changed,ld)
  --- a/arch/sh/boot/romimage/Makefile
  +++ b/arch/sh/boot/romimage/Makefile
-diff --git a/debian/patches/bugfix/x86/drm-i915-flush-tlbs-before-releasing-backing-store.patch b/debian/patches/bugfix/x86/drm-i915-flush-tlbs-before-releasing-backing-store.patch
-index ec6370826..75a9fae7a 100644
---- a/debian/patches/bugfix/x86/drm-i915-flush-tlbs-before-releasing-backing-store.patch
-+++ b/debian/patches/bugfix/x86/drm-i915-flush-tlbs-before-releasing-backing-store.patch
-@@ -50,7 +50,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
- 
- --- a/drivers/gpu/drm/i915/gem/i915_gem_object_types.h
- +++ b/drivers/gpu/drm/i915/gem/i915_gem_object_types.h
--@@ -305,6 +305,7 @@ struct drm_i915_gem_object {
-+@@ -311,6 +311,7 @@ struct drm_i915_gem_object {
-  #define I915_BO_READONLY          BIT(6)
-  #define I915_TILING_QUIRK_BIT     7 /* unknown swizzling; do not release! */
-  #define I915_BO_PROTECTED         BIT(8)
-@@ -69,7 +69,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-  void __i915_gem_object_set_pages(struct drm_i915_gem_object *obj,
-  				 struct sg_table *pages,
-  				 unsigned int sg_page_sizes)
--@@ -217,6 +219,14 @@ __i915_gem_object_unset_pages(struct drm
-+@@ -221,6 +223,14 @@ __i915_gem_object_unset_pages(struct drm
-  	__i915_gem_object_reset_page_iter(obj);
-  	obj->mm.page_sizes.phys = obj->mm.page_sizes.sg = 0;
-  
-@@ -86,8 +86,8 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-  
- --- a/drivers/gpu/drm/i915/gt/intel_gt.c
- +++ b/drivers/gpu/drm/i915/gt/intel_gt.c
--@@ -30,6 +30,8 @@ void intel_gt_init_early(struct intel_gt
-- 
-+@@ -29,6 +29,8 @@ void __intel_gt_init_early(struct intel_
-+ {
-  	spin_lock_init(&gt->irq_lock);
-  
- +	mutex_init(&gt->tlb_invalidate_lock);
-@@ -95,7 +95,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-  	INIT_LIST_HEAD(&gt->closed_vma);
-  	spin_lock_init(&gt->closed_lock);
-  
--@@ -907,3 +909,103 @@ void intel_gt_info_print(const struct in
-+@@ -912,3 +914,103 @@ void intel_gt_info_print(const struct in
-  
-  	intel_sseu_dump(&info->sseu, p);
-  }
-@@ -201,7 +201,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
- +}
- --- a/drivers/gpu/drm/i915/gt/intel_gt.h
- +++ b/drivers/gpu/drm/i915/gt/intel_gt.h
--@@ -90,4 +90,6 @@ void intel_gt_info_print(const struct in
-+@@ -91,4 +91,6 @@ void intel_gt_info_print(const struct in
-  
-  void intel_gt_watchdog_work(struct work_struct *work);
-  
-@@ -221,7 +221,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-  	struct intel_gt_timelines {
- --- a/drivers/gpu/drm/i915/i915_reg.h
- +++ b/drivers/gpu/drm/i915/i915_reg.h
--@@ -2697,6 +2697,12 @@ static inline bool i915_mmio_reg_valid(i
-+@@ -2721,6 +2721,12 @@ static inline bool i915_mmio_reg_valid(i
-  #define   GAMT_CHKN_DISABLE_DYNAMIC_CREDIT_SHARING	(1 << 28)
-  #define   GAMT_CHKN_DISABLE_I2M_CYCLE_ON_WR_PORT	(1 << 24)
-  
-@@ -234,7 +234,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-  #if 0
-  #define PRB0_TAIL	_MMIO(0x2030)
-  #define PRB0_HEAD	_MMIO(0x2034)
--@@ -2792,6 +2798,11 @@ static inline bool i915_mmio_reg_valid(i
-+@@ -2819,6 +2825,11 @@ static inline bool i915_mmio_reg_valid(i
-  #define   FAULT_VA_HIGH_BITS		(0xf << 0)
-  #define   FAULT_GTT_SEL			(1 << 4)
-  
-@@ -248,7 +248,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-  #define FPGA_DBG		_MMIO(0x42300)
- --- a/drivers/gpu/drm/i915/i915_vma.c
- +++ b/drivers/gpu/drm/i915/i915_vma.c
--@@ -431,6 +431,9 @@ int i915_vma_bind(struct i915_vma *vma,
-+@@ -457,6 +457,9 @@ int i915_vma_bind(struct i915_vma *vma,
-  		vma->ops->bind_vma(vma->vm, NULL, vma, cache_level, bind_flags);
-  	}
-  
-@@ -316,7 +316,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-  void assert_forcewakes_inactive(struct intel_uncore *uncore)
- --- a/drivers/gpu/drm/i915/intel_uncore.h
- +++ b/drivers/gpu/drm/i915/intel_uncore.h
--@@ -243,6 +243,8 @@ void intel_uncore_forcewake_get(struct i
-+@@ -246,6 +246,8 @@ void intel_uncore_forcewake_get(struct i
-  				enum forcewake_domains domains);
-  void intel_uncore_forcewake_put(struct intel_uncore *uncore,
-  				enum forcewake_domains domains);
 diff --git a/debian/patches/bugfix/x86/perf-tools-fix-unwind-build-on-i386.patch b/debian/patches/bugfix/x86/perf-tools-fix-unwind-build-on-i386.patch
 index f9baa7bd3..07410f8cb 100644
 --- a/debian/patches/bugfix/x86/perf-tools-fix-unwind-build-on-i386.patch